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Section 2
Digital Camera Design Study 
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Interface Elements

Title Bar Navigation Window Menu Bar Toolbar

LDM 
Spreadsheet

Command Window Command Line

Plot Window

Status Bar

Tabbed 
Output 
Window
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Lens Data specified by Lens Data 
Manager (LDM)

LDM spreadsheet

• 3 main windows for entering data
– Lens Data Manager spreadsheet
– System Data
– Surface Properties
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Analysis functions referred to as options 
(with input settings)

Menu or toolbar access

Re-execute

Settings can 
be modified

Q on toolbar button 
indicates “quick” option
uses default settings
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Example: Digital Camera Lens

• Small number of elements (1-3) made from common glasses or plastics 

• Image sensor (baseline is Agilent FDCS-2020) 
a. Type    CMOS 

b. Resolution   640 x 480 effective pixels 

c. Pixel size    7.4 x 7.4 microns 

d. Sensitive area   3.55 x 4.74 mm (full diagonal 6 mm) 

• Objective Lens 
e. Focus    Fixed, depth of field 750 mm (2.5 ft.) to infinity 

f. Focal length   Fixed, 6.0 mm 

g. Geometric Distortion  <4% 

h. f/number    Fixed aperture, f/3.5 

i. Sharpness   MTF through focus range  
                                       (central is inner 3 mm of CCD) 

Low freq., 17 lp/mm >90% (central)  >85% (outer) 

High freq., 51 lp/mm >30% (central) >25% (outer) 

 

j. Vignetting     Corner relative illumination > 60%  

k. Transmission    Lens alone, > 80% 400-700 nm 
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Run the New Lens Wizard

• Choose the File > New menu to launch the NLW 
– Click Next> to clear the Welcome Screen 
– Click the Patent Lens button, then click Next>

• Click the Filter button to open the patent filter dialog
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Filter Dialog

• Check the items of interest and enter Min and 
Max values for each, then click OK. 
– F/# goal is 3.5 (try 1 to 4), Field of View goal is 

26.5° (try 20 to 33), try 1 to 3 for number of 
elements.

Note that this is 
actually the semi-

field of view, 
which corresponds 
to object or image 

height
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Filter Results

• The filter returns around 12 lenses 
– Wider field and faster f/number than needed is best
– The triplet or02248 looks pretty good (f/2.4, 27.5°)

• Click the Next> button 

Note that each 
patent lens file 
includes a lens 
drawing, and 
this one shows 
three defined 
field angles
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Defining System Data

• Pupil specification 
sets the 
light-gathering 
power of the system 
and can be defined 
in several ways

• At least one 
wavelength must be 
defined, and up to 
21 are allowed, 
always entered in 
nanometers

Set Image F/Number = 3.5
Click Next

Set 546 nm weight = 2
Click Next

Reference wavelength should 
be W2 on next screen
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Field Definition

• “Field of View” (FOV) describes the size of the object 
or image that a lens can handle 
– If the object is at infinity, angular measure is used
– For finite object distances, object or image height can 

be used, with a slight preference for object-side 
definitions

• CODE V performs calculations at discrete field points 
defined with the lens
– In many cases, 3 field points are used, though some 

systems are designed for “axis only” with a single field 
– Designers often use additional field points for wider 

angle systems, and we will add an additional field point 
to this lens
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NLW Spec Data

• On the Fields page, right-click on field 2 and 
choose Insert from the shortcut menu. 
(Inserting before field 2 retains the pre-defined 
vignetting for the larger fields.)

• Click Next> and on the last page, click Done.

Enter 0, 11, 19, and 
26.5 (degrees) for 
the Y Angle semi-
FOV values of field 
points F1 to F4
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Titles and Pictures

• Choose the Lens > System Data menu
– Click on System Settings item
– Enter new title, Dig Camera Intro Seminar

• Click the Quick 2D Labeled Plot icon to make 
a lens picture

(Leave this window open for later re-draws)
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The LDM Spreadsheet

• The LDM spreadsheet contains the basic surface data
– Surface numbers, names (user labels), types, Y Radius 

of Curvature or Y Curvature (depends on Edit > 
Radius Mode setting), thickness (distance to next 
surface), glass name, refract mode (usually Refract or 
Reflect), aperture size

– Right click on any cell and choose Surface Properties
to get more surface information
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Surface Details

• Values in cells can be edited, including copy and paste

• The status of a cell is indicated by a small status 
indicator (e.g., V for variable)
– You can change the status by right clicking and using 

the shortcut menu

• Cells that are gray are defined indirectly (e.g., solves, 
default apertures, pickups) and cannot be edited
– You can still right-click these values to change their 

status

• Right-click on a cell and choose Surface Properties
to see all information (e.g., right click on the 
thickness of surface 6, the gray cell with S for 
solve)...
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Surface Properties
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First Order Properties

• The required effective focal 
length (EFL) is 6 mm

• To display first order data 
including EFL
– Choose Display > List Lens 

Data > First Order Data
– Current value is 0.9528 mm
– The Execute button updates the 

window 
– You can also place EFL on the 

Status Bar for continuous 
updates (Tools > Customize)

Execute button
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Scaling the Lens

• Select surfaces 1 to the image in the LDM spreadsheet 

• Choose the Edit > Scale menu
– Note that the surface range you selected is displayed
– In the dialog box, click the Scale Effective Focal 

Length button, and enter the desired EFL (6.0) as the 
Scale Value, then click OK.

Introduction to CODE V Training, “Digital Camera Design Study,” Slide  2-18

Analyze Distortion

• Distortion is the variation of image height from 
the idea paraxial height, h = (EFL)* (tan θ) 
– Click the Quick Field Plot toolbar button

• The left curve is astigmatism vs. field angle, the 
right curve is distortion (about 0.2% maximum)

EFL

h

θ

Paraxial ray
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Analyze MTF

• MTF is related to resolution or “sharpness”
– Choose Analysis > Diffraction > MTF
– Frequency 68 (cycles/mm) for maximum, 17 for 

increment
– On Graphics tab, enter 68 for maximum plot frequency
– Click OK — MTF is above 0.25 for all fields. 
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Vignetting/Illumination

• Vignetting is the clipping of off-axis beams by 
apertures other than the stop 
– Can be a problem or a solution (depends on specs)
– Non-zero vignetting reduces off-axis illumination

• Relative illumination includes vignetting effects

MTF text output 
includes relative 
illumination for 
each field (58.8% 
for the starting lens 
full-field)
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Other Issues

• This lens is very small – with focal length and 
detector size around 6 mm (about 0.25 inch)
– The center element has a thickness of 0.126 mm, 

too thin for practical fabrication 
– Need to consider practical aspects of small 

elements, including thickness constraints in 
optimization

• Would also need to consider glass properties
– Patent lens has “fictitious” (variable) glass with 

high index of refraction
– Higher index glasses are more expensive
– May want to constrain glass to lower index 
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Workshop 2-1: Telephoto Lens

• A telephoto lens has a total length from first 
vertex to image plane that is less than the 
effective focal length. 

• We’re going to design a 135-mm focal length, 
f/3.5 telephoto lens for a 35-mm single-lens 
reflex (SLR) camera. Design target is MTF > 0.5 
at 30 cycles/mm, and MTF > 0.2 at 60 
cycles/mm.

• Use the New Lens Wizard to restore the CODE V 
Sample Lens called TELEPHOT.
– Change the Pupil Specification to Image f/number

and enter 3.5 as the value.
– Don’t change the wavelengths or weights.
– Change the Field Type to Paraxial Image Height and 

enter Y values of 0, 15.3, 21.63.
– Don’t alter the vignetting.
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Workshop 2-1: Telephoto Lens (2)

• Draw the lens. 

• Use Edit > Scale to scale the lens data by a 
factor of 1.35. Make sure you scale all surfaces 
(1 through Image).

• Verify the effective focal length using Display > 
List Lens Data > First Order Data.

• Compute the diffraction MTF with a maximum 
frequency of 60 and increment of 5.

• Save the lens for future use.
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Optimization

• Optimization is used to improve the optical 
quality of a starting design  
– Requires variables, parameters that can be altered
– Requires an error function, a quantity that 

correlates with quality (smaller is better, zero is 
“perfect”)

– Requires constraints, or boundary conditions

• CODE V’s optimization is called Automatic Design
– Uses a constrained damped least squares (DLS) 

method
– Provides a sophisticated default error function and 

other intelligent defaults
– User can re-define everything, including the error 

function
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Optimization Plan

• Use LDM to define variables 
– All curvatures, all thicknesses, all glasses

• Define general constraints on thickness and glass

• Define a specific constraint on EFL, others as 
needed
– Distortion may require a constraint

• Draw the lens at each cycle

• Optimize with default weights

• Analyze MTF and distortion

• Re-optimize with field weights adjusted to balance 
performance across fields
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Define Variables

• Vary radii of surfaces 1-6, 

• Vary thickness of surfaces 1-5 plus image thickness
– Don’t vary thickness of 6 (it has a PIM solve)

• Vary all glasses (converted to fictitious glass)

Right-click

* Highlight multiple cells 
by left-click and drag, or 
use CTRL key
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Variable glasses must be fictitious 

• Fictitious glass is defined by its index (Nc) at a 
central wavelength and its Abbe (V) value at 
two extreme wavelengths (typically d, F, & C 
wavelengths)

• V = (Nc-1)/(Ns – NL)

• Two different formats are supported

Where:

Nc = index at central wavelength

Ns = index at short wavelength

NL = index at long wavelength

Dispersion = (Ns – NL)

n = 1.5168
V = 64.17

1.5168:64.17
- or -

5168.6417
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Optimizing with fictitious glass

• Default is to vary both index and dispersion (typical 
use)
– Use Reviews > Variables & Couplings to vary only 

the index, only the dispersion, or constrain the glass 
to always lie on a defined boundary of a glass map

• After optimization, fictitious 
glasses can be converted to 
real glasses with the help of 
the CODE V sample macro 
GLASSFIT.SEQ
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Pre-AUTO Lens

• The LDM spreadsheet shows the values, 
variables, and paraxial image solve 

• Quick 2D Labeled Plot shows starting form
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Variables Ready for AUTO

• It’s good to review your variables before optimization 

• Choose the Review > Variables and Coupling menu

A “Coupling Code”
of 0 means “vary,”
while 100 means 
“freeze,” though 
frozen parameters 
are not shown in 
the review 
spreadsheet.
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Automatic Design Settings

• Automatic Design is an incredibly flexible design tool
– Requires a ray-traceable starting lens with one or more 

variables (done in LDM) 
– Provides several different built-in error functions, plus 

user-defined error functions
– Provides many types of constraints to set 

requirements, plus user-defined constraints
– Runs local optimization by default, but very effective 

Global Synthesis optimization can be used with a single 
click

• Input dialog is divided into a number of tabs 
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General Constraints Tab

• General constraints prevent non-physical solutions 
(e.g., negative edges, glass with n = 99)
– They apply to all surfaces and zoom positions, but can 

be overridden by specific constraints

Enter 0.9 for minimum 
center thickness, and 
0.8 for minimum edge 
thickness (keep other 
defaults).
Delete glass SF4 and
change Map 3 glass to 
SF2.
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The Glass Map

• The optimization glass map is defined on an index vs. 
dispersion (NF - NC) plot
– The default glass map boundaries form a 4-sided polygon 

containing most real glasses with reasonable cost

Default boundaries (RM p. 17-32)

Tools > Macro Manager 
> Sample Macros > 
Materials > vp_plot.seq
(boundaries added 
separately)
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The Glass Map

• Making this a smaller 3-sided polygon can restrict 
variable glasses to a lower index region of generally 
less expensive glass types
– Use SF2 to define the 3rd vertex



Introduction to CODE V Digital Camera Design Study • 2-18

Copyright © 2009 Optical Research Associates 

Introduction to CODE V Training, “Digital Camera Design Study,” Slide  2-35

Specific Constraints

• Specific constraints are boundary conditions 
imposed by you, to force the optimizer to maintain 
requirements 
– Most common specific constraint is EFL or another 

scale-holding constraint, as shown in first example
– There are many things you can constrain, divided 

into 8 categories (optical, manufacturing, real ray, 
etc.)

– Constraints can be held to a value (=), bounded 
(> or <), minimized, or only displayed 

• Try to use the minimum necessary constraints
• In this case, EFL is needed, others may be added 

later
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EFL Constraint Entry

– Enter equality constraint, EFL = 6 mm

Select “=“
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Other Settings

• Common changes for optimization, 
– Type of error function
– # of rays traced, ray grid control
– Exit controls (max cycles, improvement %, interactive)
– Weights on error function components
– Global synthesis

• Drawing the lens 
on each cycle is 
often useful 
(Output Controls)
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Option Sets

• Settings entered in any option input dialog are 
saved for the current CODE V session 
– As long as you keep the output window open, you 

can use the Modify Settings button to view and 
change settings

• To save the settings for a future session, click the 
Option Set button, then use the Save As button
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The Error Function

• Five types of error functions in CODE V
– Weighted transverse ray aberrations 

(default, spot size)
– Wavefront variance (OPD-based)
– MTF
– Fiber coupling efficiency
– User-defined

• Contains only image errors in the default case
– Constraints are handled separately 

(Lagrange multipliers)
– Constraints can be included with 

aberrations (weighted)
• Unnecessary for most constraints
• Can be useful for non-linear constraints 

(e.g., distortion)

Usually sufficient

Must start with 
good system
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Default Error Function

x

y

• Default error function is a weighted RMS spot size
– Transverse ray aberrations used (ΔX and ΔY from chief 

ray)
– All skew rays (no rays on meridional or sagittal planes)
– Traced for each wavelength, field, and zoom position

• Weighting factors are used
– Wavelength weighting (default is same as LDM)
– Field weighting (default is same as LDM, users may wish 

to override this)
– Aperture weighting (default tries for tight core with 

some allowed flare)
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AUTO Output Header

Error function 
weights (default or 
user-entered)

Specific (user entered) and 
general (default or user) 
constraints

Commands 
generated by 
option settings
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Per-cycle Output

Error function value, change, 
and field components

Current lens prescription

Active constraints, 
specific constraint 
values, and Lagrange 
multiplier constraint 
costs

First order parameters
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Analysis

• Re-run MTF and Quick Field Plot windows 
– Distortion (full field) is about -2.6% (4% allowed)
– MTF at 51 lp/mm is below 25% for some fields

Weighting field 
components in AUTO, 
possibly independently 
in X and Y, can most 
likely shift the solution 
to bring all curves 
above 25% line 
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Weights and Constraints

• Error function weights have strong effect on solution 
– Frequently determined by trial and error, based on 

analysis results and with use of Edit > Undo if a trial 
solution is very bad

– Field weights have X and Y components

• Weights are found on the Error Function Weights tab
– Example below is for the X components of field weights
– Next slide shows a set of weights that work pretty well 

for this case 
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Final Field Weights

NOTE: Any 
omitted field 
weights will 
use the LDM 
defaults 
(usually 1.0)
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2D Image Simulation
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2D Image Simulation (cont.)

Image tilted 10°
in XZ plane

Original Picture

Image@focus
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Conclusions - NLW/AUTO

• The New Lens Wizard provides a step-by-step 
method for generating starting points from 
previous work 
– You can change system data in the NLW
– You will usually need to also change things such 

as variables in the LDM

• Automatic Design is a flexible method for 
improving the performance of a starting design
– Multiple error function types are supported
– General and specific constraints allow detailed 

control of boundary conditions
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Workshop 2-2: Optimize Telephoto Lens

• Prepare the lens for optimization by adding 
additional variables in the LDM:
– All curvatures (except object, stop and image) are 

currently variables
– Select all thicknesses from surface 1 through 9 

and make them variables
– Vary the (flint) glasses on surfaces 4 and 9

• Optimize with 1 constraint: EFL = 135.  Draw 
the lens at each cycle.

• Compute the diffraction MTF with a maximum 
frequency of 60 and increment of 5.  You should 
have on-axis MTF > 0.5 at 60 cycles/mm.
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Workshop 2-2 : Optimize Telephoto Lens (2)

• A telephoto lens should be shorter than its focal length 
(S1 to image < EFL). Reoptimize with a constraint to keep 
the Overall Length (under “Manufacturing/Packaging”) 
from surface 1 to the image < 120. (** Note: The First 
Order Data lists the overall length from S1 to S(I-1) as 
“OAL.”) 

• Re-compute the MTF. Did it change much?

• An SLR lens must have an image distance (back focal 
length, BFL) > 40 mm. Reoptimize with this constraint, 
found under “Optical Definitions.” Did it change the MTF?

• The rear element semi-diameter is somewhat large for a 
typical SLR lens mount. (A typical SLR mount requires a 
semi-diameter < 12.5 mm.) See how small you can make 
it while keeping the on-axis MTF > 0.5 at 30 cyc/mm. Use 
the Max Semi-diameter constraint found under 
“Manufacturing/Packaging” at surface 10.
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Tolerancing Basics

• Tolerance analysis is an important step for any 
design that will be fabricated

• The goal is to identify and simulate possible 
fabrication errors and predict their effects
– Ideally this should be done in terms of 

measurable quality criteria such as MTF, RMS 
wavefront error, or coupling efficiency

– Should also simulate the effects of assembly or 
end-use adjustments (compensators)

• CODE V has several tolerancing features
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Tolerance Analysis Functions

• TOR is CODE V’s primary option for calculating the effects of 
manufacturing and assembly errors on MTF, RMS wavefront 
error, fiber coupling efficiency, or polarization dependent 
loss
• The name TOR comes from Tolerancing, Ray-based 

(as opposed to paraxial-based tolerancing)
• It uses a very fast algorithm that provides information 

about individual tolerance sensitivities (i.e., performance 
drivers) and it accurately predicts system performance

• Many of the details of TOR will be discussed in the 
Introduction to Tolerancing section
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Tolerance Analysis Functions

• CODE V has other tolerancing options
• TOL – tolerance first-order and third-order properties 
• TOD – tolerance on chief ray distortion
• TOLFDIF – macro for finite-difference tolerancing 

using user-defined performance measures
• TOLMONTE – macro for Monte Carlo tolerancing 

using user-defined performance measures

• These other tolerancing options will not be covered 
this week
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Fab & Assembly: What Can Go Wrong?

• Murphy’s Law in action 
– Anything that can go wrong WILL go wrong
– No physical device can be built perfectly, so possible 

errors must be anticipated and simulated
– The greater the required precision, the greater the cost 

• Typical tolerances (partial list)
– Test plate fit (DLF) – measures surface shape error
– Thickness (DLT) – measures glass or air thickness
– Index and dispersion (DLN, DLV) – glass errors
– Surface tilt is usually measured as wedge 

(TIR = total indicator runout)
– Barrel tilt (BTI) measures the tilt of an element or 

group
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Compensators

• Compensators simulate adjustments made during 
assembly or alignment
– Compensators minimize loss in performance
– They are not allowed to improve the performance by 

themselves but only to minimize performance loss
– Compensation is done simultaneously over field and 

zoom (by default)
– Compensation can be done separately for each field 

and zoom

• Any tolerance parameter can be a compensator
– Most compensators relate to moving an element or 

group of elements (shift along Z, tilt, decenter, etc.)
– Default compensator is shift of the image surface 

(DLZ SI)
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Statistics

• Tolerances specify the plus and minus limits that 
are possible around a nominal value (range) 
– You try to achieve the nominal value, but the 

as-built values will be randomly scattered within 
the range

– Therefore each unit you build is slightly different

• Performance prediction requires statistics
– You want to know the yield (percentage of as-built 

systems with acceptable performance) or 
probability of success for unit-one systems

– Such predictions can be obtained from Monte 
Carlo simulation, or from simulated Monte Carlo 
based on assumption of large number (> 10) 
tolerances  
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Inverse vs. Sensitivity Mode

• Sensitivity analysis means taking a set of assumed 
tolerance values and predicting their performance 
effects
– This requires a way to determine the assumed 

tolerances
– Could be based on fabrication capability (or guess 

work)

• Inverse sensitivity means determining tolerance 
values that cause a certain performance change
– This is done for each tolerance, scaling so that each 

tolerance causes the same small drop in performance
– Limits and rounding are applied to the values to make 

sure they are realistic, so in practice, not all tolerances 
will contribute the same error 
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Default Tolerance Run Input

• Tolerances are associated with surfaces and are 
thus defined in the LDM as part of lens data
– You can define tolerances in great detail, for 

individual surfaces or groups of surfaces

• If you run TOR without defining tolerances, a 
default set is defined for you
– It includes all the basic surface tolerances plus 

group tolerances for single elements and 
cemented elements

– This is often a good starting point, but it does not 
contain group tolerances for non-cemented 
sub-assemblies, since CODE V does not know the 
mount structure of a lens
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Prepare the Lens

• Place the lens at best focus by clicking the Quick 
Best Focus button on the tool bar

– TOR works best when the lens is at best focus
– Quick Best Focus runs the RMS Wavefront 

Analysis option and sets the image surface 
thickness for best focus
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Run MTF Tolerance Analysis

• Choose Analysis > 
Tolerancing > MTF

• In the dialog, enter 
17 for the Spatial 
Frequency for each 
of the four fields 
(Lines per MM 
column)

• Click OK. 
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Tolerance Output

• TOR generates significant output, including:
– Tolerance sensitivity tables for each field and zoom 

showing the performance change with compensated 
plus and minus tolerance change

– A performance summary table for each field
– If CODE V is determining the tolerance set (inverse 

sensitivity mode), two tables of tolerance values are 
printed (centered & decentered tolerances)

– A final 2-Sigma (98% probability) performance 
summary for all fields and zooms

– A cumulative probability plot

All of this output will be covered in detail in the 
Tolerance Analysis section
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Example Output

Performance Summary 
Table & Graph

Spec: 
F1, F2: MTF > 0.90 
F3, F4: MTF > 0.85
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Review > Tolerances (LDM)
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Special Features 

• CODE V has many special features not shown in 
this example, including
– Zoom (multi-configuration set-up)
– Tilted and decentered systems
– Non-spherical surfaces
– Solves and pickups
– Gradient-index (GRIN) materials
– Polarizers and birefringent elements
– Diffractive surfaces


